Dear Customer,
 
As part of our continuous improvement process concerning application security and functionality, we would like to inform you that Internet Explorer 7 and 8 browsers will no longer be supported by Microsoft from January 12th 2016. (Microsoft Support)
 
We therefore recommend that you install a more recent version of Internet Explorer (9 or a later version), or use Google Chrome and Mozilla Firefox browsers, which are particularly well suited to our services.
 
For security reasons, from December 1st 2015, our applications will no longer be accessible through Internet Explorer 7 or 8.
 
Thank you for your understanding.

KI Finans

Please Log In!